gelöst Simulation LM3478

moma2

Member
Member
Hallo zusammen

Ich bin relativ neu mit LTSpice dran und versuche mich darin den LM3478 von TI zu simulieren. Ich möchte damit eine SEPIC-Schaltung realisieren.

Ich habe dazu folgende Schritte ausgeführt:
- PSpice Transient Model von TI heruntergeladen (
Bitte, Anmelden oder Registrieren um den Link zu sehn!
)
- LM3478_TRANS.lib file im LTSpice geöffnet und auf der Zeile .SUBCKT LM3478_TRANS ... -> "Create Symbol"
- Danach die Komponente (von Autogenerated) ins Schema eingefügt.

Leider erhalte ich wenn ich simuliere die Fehlermeldung:
"u2:v_ifa: requires a minimum of 5 parameters. Only 3 specified."
Habe das Schema hochgeladen, damit ihr euch dies anschauen könnt.

Mache ich etwas beim Import des Bauteils falsch? Welche Parameter muss ich noch definieren? Schafft es jemand von euch den LM3478 zu simulieren?

Bin um jede Hilfe dankbar :)

Danke schon einmal und Gruss
 

Anhänge

helmutsennewald

Absoluter Profi
Member
Hallo moma2,

ich habe das Modell LM3478_TRANS.lib von TI etwas modifizieren müssen.

1. LTspice mag keine unnötigen geschweiften Klammern {}, weil die in LTspice eine besonder Bedeutung haben.

2. Mike, der Entwickler von LTspice, hat vor einigen Monaten die Anforderung an die Definition von PULSE-Quellen in der Weise geändert, dass jetzt im Prinzip praktisch alle Parameter angegeben werden müssen. In dem Modell gibt es aber PULSE 0 0 0 mit nur 3 Parameter. Das habe ich dann auf eine Gleichspannung 0 geändert und den Rest mit ; zu Kommentar gemacht. Mit dieser Inkompatibilät hat Mike uns einen Bärendienst erwiesen. Ich hätte nicht gedacht, dass das auch in Modellen zuschlägt.
0 ; PULSE 0 0 0

Ich habe dir ein funktionierendes Beispiel angehängt. Es enthält die modifizierte .lib und ein passendes Symbol. Diese beiden Dateien immer in das Verzeichnis deines Schaltplanes kopieren.

Du solltest unbedingt bei den 22u Kondensatoren und Spulen den Serienwiderstand eintragen. Rechtsklick auf das Bauteil und dann in der Spalte bei "Series Resistance" eintragen. Die Serienwiderstände haben einen Einfluss auf das Regelverhalten des Wandlers und auf den verbleibenden Spannungsripple.

Gruß
Helmut
 

Anhänge

Zuletzt bearbeitet:

moma2

Member
Member
Hallo zusammen

Danke für die schnellen Antworten und Hilfen.

Die Simulation funktioniert nun, werde dies nun weiter verfeinern (mit Seriewiderständen etc.).

Gut zu wissen, was da alles an Modifikationen nötig ist um dies zum Laufen zu kriegen!

Nochmals danke und Gruss
 

helmutsennewald

Absoluter Profi
Member
Hallo moma2,

mir ist aufgefallen, dass deine Spulen gar nicht gekoppelt sind obwohl da noch ein dicker Punkt dran ist. Das bedeutet, dass da schon einaml eine SPICE-Directive mit Kopplung im Schaltplan war. SEPIC geht ja mit gekoppelten und mit nicht gekoppelten Spulen. Gekoppelt bedeutet, dass beide Spulen auf dem gleichen Kern sind. Falls du eine gekoppelte Spule verwendest, dann musst du eine SPICE-Directive für Kopplung K in den Schaltplan einfügen.

K1 L1 L2 1

Faktor 1 bedeutet ideale Kopplung. Reale Spulen haben eher 0,95 bis 0,98. Allerdings dauert die Simulation meistens länger, wenn man K ungleich 1 macht.

Im Anhang das Beispiel mit den gekoppelten Spulen.
Die Induktivität mit 1,5uH kommt mir ziemlich klein vor. Ich habe sie mal auf 3,3uH erhöht. Außerdem habe ich das RC-Filter am Stromsense-Widerstand korrigiert. Eventuell geht es auch mit 0Ohm, wenn der C des RC-Glieds direkt am Eingang des Reglers sitzt.
Der Koppel-C zwwischen den Spulen mit 22uF scheint mir viel zu groß zu sein. Ich habe ihn auf 2,2uF reduziert.
 

Anhänge

Zuletzt bearbeitet:

moma2

Member
Member
Hallo Helmut

Danke für den Hinweis mit der Kopplung, diese habe ich vergessen. Ich möchte die beiden Spulen in meiner Schaltung gekoppelt haben.

Genau die Spulengrösse und die Grösse des Koppel-Cs wollte ich eigentlich genauer simulieren und die geeignetsten Werte herausfinden. Ich werde nun einmal bei deinen Werten starten.

Der Widerstand am ISEN Eingang sollte ursprünglich eine Möglichkeit bieten eine Slope Compensation zu realisieren:
Bitte, Anmelden oder Registrieren um den Link zu sehn!


Was mich aktuell noch irritiert an der Schaltung ist, dass idie Ausgangsspannung bei z.B. einer Last von 120Ohm nicht auf 12V hochkommt, sondern nur auf 11.6V. Die FB-Spannung ist dann auch nicht bei 1.26V wie dies der Regler eigentlich will.
Bei einer kleineren Last (z.B. 1kOhm) funktioniert dies. Allerdings habe ich dann ein unschönes Verhalten mit der OVP Protection des Reglers bei zu kleiner Last.

Fällt dir diesbezüglich noch etwas ein?

Gruss
 

helmutsennewald

Absoluter Profi
Member
> Was mich aktuell noch irritiert an der Schaltung ist, dass idie Ausgangsspannung bei z.B. einer Last von 120Ohm nicht auf 12V hochkommt

Es ist mir auch schon aufgefallen, dass nie 12V herauskommen. Leider gibt es kein Beispiel mit TINA-TI auf der Webseite um das mal mit deren Simulator zu testen. Es gibt zwar ein PSPICE-Modell, aber da gehe ich davon aus, dass dafür die Demoversion nicht reicht und eine Vollversion habe ich nicht.

Mein Vorschlag ist, zwecks Optimierung der Spulen, eine praktisch identische SEPIC-Schaltung mit gleicher Taktfrequenz mit dem LT3757 zu simulieren. Diese Schaltung simuliert hundert mal schneller. Damit kann man sehr gut die Auswirkung der Spulen auf die Ströme analysieren. Dabei bitte auch I(L1)+I(L2) plotten. Auf diesen Spitzenstrom muss man die Spulengröße auswählen. Ich würde da aber den eingeschwungenenn Zustand betrachten. Außerdem bitte den maximalen Source bzw. Drainstrom beachten.
Ich habe die Datei zum simulieren angehängt.
 

Anhänge

dazz

Member
Member
Sorry guys, I don't speak german, hope you don't mind a quick post in english to say thanks to Helmut for the above LM3478 LTspice model fix. Worked a treat.
 

Benutzer welche diesen Thread betrachten (Mitglieder: 0, Gäste: 1)

Benutzer welche auf diesen Thread geantwortet haben: 3 Sehe alle

Oben